Jump to content

Error compiling on Ubuntu 16.04 LTS


Recommended Posts

Hi all, there is something bad with latest SF Core or do I miss something from requirements?
I got an error on Linux Ubuntu 16.04 LTS using lates SF from master:

Scanning dependencies of target shared
[ 25%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o
[ 25%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/OpenSSLCrypto.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/SHA1.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/Authentication/AuthCrypt.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/HMACSHA1.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/BigNumber.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Cryptography/ARC4.cpp.o
[ 26%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Database/QueryResult.cpp.o
/home/wowsc/workspace/wow-mop-server/SkyFire_548-master/src/server/shared/Database/QueryResult.cpp: In constructor ‘PreparedResultSet::PreparedResultSet(MYSQL_STMT*, MYSQL_RES*, uint64, uint32)’:
/home/wowsc/workspace/wow-mop-server/SkyFire_548-master/src/server/shared/Database/QueryResult.cpp:82:41: error: cannot convert ‘bool*’ to ‘my_bool*’ {aka ‘char*’} in assignment
         m_rBind.is_null = &m_isNull;


Please help, anyone?

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

error: cannot convert ‘bool*’ to ‘my_bool*’ {aka ‘char*’} in assignment
         m_rBind.is_null = &m_isNull;


same error over and over (tested on Ubuntu 18.04.02 LTS).

Which readme, can you help please with a better "clue"? ;)


Link to comment
Share on other sites

Installed MySQL 8.0 on Ubuntu 18.04 LTS (no more MySQL error) but ...

Moooore errors..

[ 40%] Building CXX object src/server/game/CMakeFiles/game.dir/Handlers/VehicleHandler.cpp.o
/home/?????/workspace/server-wow-mop-full-localhost/SkyFire_548-master/src/server/game/Handlers/VehicleHandler.cpp:224:133: error: 
      cannot pass non-trivial object of type 'ObjectGuid' to variadic method;
      expected type from format string was 'unsigned long' [-Wnon-pod-varargs]
  ...SF_LOG_ERROR("network", "HandleEjectPassenger: Player %u tried to eject invalid GUID " UI64FMTD, GetPlayer()->GetGUIDLow(), PassengerGUID);
/home/?????/workspace/server-wow-mop-full-localhost/SkyFire_548-master/src/server/shared/Logging/Log.h:151:56: note: 
      expanded from macro 'SF_LOG_ERROR'
/home/?????/workspace/server-wow-mop-full-localhost/SkyFire_548-master/src/server/shared/Logging/Log.h:125:57: note: 
      expanded from macro 'SF_LOG_MESSAGE_BODY'
                sLog->outMessage(filterType__, level__, __VA_ARGS__);   \
1 error generated.
src/server/game/CMakeFiles/game.dir/build.make:3302: recipe for target 'src/server/game/CMakeFiles/game.dir/Handlers/VehicleHandler.cpp.o' failed
make[2]: *** [src/server/game/CMakeFiles/game.dir/Handlers/VehicleHandler.cpp.o] Error 1
CMakeFiles/Makefile2:799: recipe for target 'src/server/game/CMakeFiles/game.dir/all' failed
make[1]: *** [src/server/game/CMakeFiles/game.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make: *** [all] Error 2


?? Any help please? Thanks in advance.


Link to comment
Share on other sites

Well...? That means it can't be compiled or it is something from my configuration?

P.S. I have everything updated and Ive tested with Ubuntu 18.04 LTS and all program versions are above from that readme..

Can you help please? Ty.



There's no chance in compiling.. It seems that I can't get after this error with VehicleHandler.cpp and compiler stopped (but how Travis can?)

1 error generated.
src/server/game/CMakeFiles/game.dir/build.make:3302: recipe for target 'src/server/game/CMakeFiles/game.dir/Handlers/VehicleHandler.cpp.o' failed



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.